CDROM-Guide forums

CDROM-Guide forums (
-   PS2 Modchip Help & Installation (
-   -   V4 jap PS2 infinity mod dead? (

felchi80 Jun 10, 2005 09:47 PM

V4 jap PS2 infinity mod dead?
OK... i think my PS2 is dead now. I installed an infinity modchip. First time i tried booting, I get the ps2 setup page. I remove a dvd that was inside, put the firmware update cd that i burnt and changed the display to english. Now I press on the reset button and.... nothing... blank.... the tray doesn't even eject anymore. The drive is not even spinning... So i remove the cd manually by remove the drive cover... put it back together... still nothing. Getting blank screen still... i get the blue LED going too. Sometimes at boot it's just off and after a few seconds it turns on and the screen blinks once.... other times it just goes on instantly when I press reset... when I press on eject, it just starts blinking, and stops and screen blinks once.
So... i decide to remove the modchip and boot again... it's still the same thing! sigh... i think it's dead...i dont think there was a short or anything... coz it booted the first time (although there were no signs that the mod chip was running)...
any input will be appreciated.... thanks

9Homersimpson9 Jun 12, 2005 11:09 AM

Gettinh the PS2 set-up page after the install means you were crushing a wire on the modchip inside the PS2, sounds like you may have blew the board or a few fuses...

Try sc****** in between each leg on the bios chip, were you would have soldered a few wires too, use a pin to do it, you may have bridged one of the legs that is so small that your eyes cant see it!

Let us know how you get on...


9Homersimpson9 Jun 12, 2005 11:10 AM

I have no idea why it just blanked out S C R A P I N G.

But just follow them and you may recover your ps2.

felchi80 Jun 13, 2005 01:05 PM

will try that.
what do you mean by crushing a wire on the modchip?
do you mean "crossing"? as in "shorting"?
if that's the case... if it possible that the modchip has blown too?
is it possible to check for fuses too? if so... where should i be looking?
thank again :)

ghost2_fitter Jun 14, 2005 05:13 PM

check out your BA chip, pin 8 to ground for continuity, also the fuse next to it.

Although it booted at first there also could be some loose solder or flux on the board causing a short. Recheck and clean up all your points.

For all your U.K premod, chip and fitting needs.

Full postal service, 3 month warranty on all sales.


felchi80 Jun 15, 2005 09:01 PM

Ok.... i have a question. Which BA chip should I be looking at? From there picture I took, is it the one on the left or the right? I've been googling and it seems that lots of ppl ask for checking BA chip and the ps14 fuse.
I have checked the PS14 underneath the BA chip on the right and it is shorted (meaning ok right).
As for the pin 8 on the BA chip, i dont know which pin is it, so i tried the pins next to the middle big ground pin of the BAs.... it turns out that the right BA is fine, but i get a shorted pin to ground on the left BA (circled in red).
is this normal?
It seems that a lot of problems related to eject buttons, no video, no sound, no disc spinning are related to this BA chip. I really hope this is my case....

All times are GMT -5. The time now is 01:48 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1996-2009 All rights reserved