CDROM-Guide forums

CDROM-Guide forums (http://www.cdrom-guide.com/forums/index.php)
-   Device Driver Questions (http://www.cdrom-guide.com/forums/forumdisplay.php?f=7)
-   -   cdrom drive doesn't appear in my computer (http://www.cdrom-guide.com/forums/showthread.php?t=288671)

brodieros Jan 07, 2008 05:50 PM

cdrom drive doesn't appear in my computer
 
I can't use my Toshiba MK8032GSX it won't even show up im my computer. When i go to properties of C: and then to hardware it says:
Device Status: Windows cannot load the driver for this hardware. The driver may be corrupted or missing (Code 39)

i have my Recovery and Applications/Drivers DVD cd but i can't use it because my cdrom wont' work. any ideas?

chandler68 Jan 07, 2008 09:17 PM

Try deleting the upper/lower filters:-

[COLOR="Red"]WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.[/COLOR]
1. Click Start, and then click Run.
2. In the Open box, type regedit, and then click OK.
3. Locate the following registry subkey:
HKEY_LOCAL_MACHINE/System/Curretcontrolset/Control/Class/{4d36e965-e325-11ce-bfc1-08002be10318}
4. On the File menu, click Export.
5. In the File name box, type savedkey, and then click Save.
6. Click the REG_MULTI_SZ data type UpperFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes. NOTE: If this data type is missing, continue to the next method.
7. Click the REG_MULTI_SZ data type LowerFilters, and then click Delete on the Edit menu. When you are prompted to confirm the deletion, click Yes.
8. Quit the Registry Editor, and then restart the computer.

colin.

ralva Jan 08, 2008 07:40 AM

cd rom drive not detected
 
even i had the same problem, did delete the filters, uninstalled the drivers and controllers. but still the cd rom drive not detected in xp. i even had windows 98, but even when i opened that still same problem exists. in device manager the error is 'the device cannot start-code10' in both xp and 98.

the drive is detected in bios so i tried to boot directly from cd, but its coming as 'please insert system disk and press enter to continue'.

please help....

chandler68 Jan 08, 2008 07:11 PM

The drive needs testing in another computer to see that it is working OK or not.

If it is try a new data cable and make sure the power plug is seated correctly, try swaping the power plugs round to see if this makes any difference.

Also try reinstalling the IDE drivers that should be on the mobo's utility disc.

colin.

ralva Jan 08, 2008 11:45 PM

i think the cable and cd drive are correct, i attached to the primary ide connector and it works fine.

one more thing is that after i delete filter and uninstall the drive and reboot, the drive doesnot appear. but after scanning for new hardware, the drive icon appears in the 'my computer' but when i insert any cd it shows that 'the cd is not readable as it is corrupt' .
also at this moment when i checked the registry there is no filters value present- is this normal.

chandler68 Jan 09, 2008 09:16 PM

I take it that the drive is being detected in the BIOS, and the drive is being shown in "Device Manager" without any errors being shown.

If so try updating the drivers for it in Device Manager.

After deleting the upper/lower filters XP should replace them with fresh copies.

colin.


All times are GMT -5. The time now is 02:10 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1996-2009 CDROM-Guide.com. All rights reserved