CDROM-Guide forums

CDROM-Guide forums (http://www.cdrom-guide.com/forums/index.php)
-   Dreamcast (http://www.cdrom-guide.com/forums/forumdisplay.php?f=14)
-   -   -Problem with backin' up Psyvariar2 (http://www.cdrom-guide.com/forums/showthread.php?t=275529)

Suzuke Oct 13, 2004 01:52 AM

-Problem with backin' up Psyvariar2
 
Guyz, I need your help! I already killed 4 CD-R's (3 700Mb and 1 800MB). I can't get Psyvariar2 running.

I ripped Psyvariar2 and used 'extract' on the track03.iso file. After unpacking it, I was suprised- only 160MB of data??? 'Can that be true?', I asked myself. Well, after checking the files it everything seemed to be ok, so I burned the files as always (selfboot, of course).
I put the CD into my DC and the DC logo came up, follow by the 'Made by or under license blabla' stuff... and a BLACK SCREEN!!
I thought maybe there's a prob with my dummy file, so I've created a new one and burned the files again. The same prob'! After biting in my desk, I burned the disc with a larger dummy file on a 800MB CD-R, and then -without- a dummy on a 700MB CD-R. Always the same result. :bawling:

What's wrong? Do you think there are more files on the disc but T.T. simply stoped reading them out (by the way, I read somewhere that a guy had a prob' that his DC stops reading the GD anymore after 3mins/30mins/3h (I think it was the last one, 3h, don't know it anymore). If it was after 3h, well, my DC stoped reading the GD after 3hours too!)?

Can anyone help me? I even edited the IP.BIN file by myself 1time (and 'placed' a boot logo in it), but I get a black screen after booting all the time.
I have the fear that my DC maybe stops reading the GD after some hours too like the one of this poor guy I mentioned before does. But Psyvariar2 is a REALLY short game, so I can be true that it has only 160MB of data... Gee, I'm so confused right now. I hope that anyone of ya guyz can help me.

-Suzuke-

Suzuke Oct 14, 2004 12:07 AM

NOTE: No, my serial cable is OK. And the game really has only 160MB of data.

No one here who can help??

Suzuke Oct 15, 2004 04:52 PM

My dear CD-R's, R.I.P., guyz, r.i.p. :( :(
 
I tried to burn Psyvariar2, Ikaruga, Sakura Wars 4 and Soul Calibur.

Psyvariar 2 and Soul Calibur won't go any further as the screen 'Produced by or under license from...' and Psyvariar2 and Sakura Taisen4 always reset the console and bring me back to the 'boot manager' (start screen).

I wasted now over 10CD-R's and I'm really fu*** **, I tell ya!!
But, for example, the serial slave from marcus works, I even edited the IP.BIN file a lill' and added a dummy along with a .txt file the to disk (it loads now in seconds, 680Mb dummy, ya know). Or one of the other stuff- I even edited the DC internet browser's files to get access to some DC only scripts features (e.g. like a dancing baby on your TV (!), or a button which will let your vibration pack go crazy if ya click on it, etc.) and burned it. It works, too! So what the fu*k is wrong??

Does no one have a idea? I thought here are some of the good old DC burnin' proofs active in this Forum... :rolleyes:

-Suzuke-

Suzuke Oct 15, 2004 07:33 PM

I tried to get Psyvariar2 to work, and again, I failed. This time I edtied the 1ST_READ.BIn like in the tutorial I found, it's from vETi^dC for dcisos.de .

---
Make the games run:
-------------------

Now you have ripped the whole data from the GDRom. As you see,
some games are very big, and don t fit on normal cd or even
a 80 minutes blank.To fit the data you have to downsample
some files. You can find some tutorials on diffrent
DC sites. Keep your eyes open. Now you have fit the data,
and you want to burn it. Ok, now we need Cdrecord.
Now you have to burn the first session of the game.
To do this take a look at the Echelon selfboot tutorial.
Now you have burned the first session with the LBA
0,11702. Note down this number.
Now it s time for the part to hack the 1st_read.bin.
You have to do this,because Binhack doesn t modifies
the 1st_read complete.This is the reason that the people
can t get their games to work.

1. Open the 1st_read.bin with the hexeditor. You know
that the original GDRom starts from the LBA 45000.
But some people forgett that. You need space for the
ip.bin in the 1st_read.bin. Because of this we have now
the LBA 45150.

2. You got now the correct LBA. Transform the value into
a hex value. The right value is B05E. (45150=B05E)
But be carefull. The value is byte-swapped, and you
have to read it 5EB0.

3.Ok now lets search for that hex value in the 1st_read.bin.
Note down all offsets you find. There are always 2 offsets.
One offset for 5E, the other B0. Write both down, and
continue your search with F3. Maybe you will have
over 50 hits or even more, maybe you have only 4 or 5 hits.
It s from game to game diffrent.

4.To find the right one, isn t all too difficult.You always
have to change two offsets. That means,when you have 5
hits, you have to modify 2 of them. The right ones are
always near to each other. Here is a example I do with
the 1st_read.bin of DY.A.I.E C.P:


1. 234fe
234ff

2. 9a11c
9a11d

3. b3744 <---
b3745 <---

4. b3b14 <---
b3b15 <---

5. c28o8
c2809


5.Now you see those 4 offsets: b3744+b3745 and b3b14+b3b15
Remember 2 offsets are one value (b3744=5E)
(b3745=B0) (5E+B0). Okay now you only have to change these 4
offsets into 5E=96, B0=00.Right then save the file.
Now you have the modified 1st_read.bin. Now run Bihack
on the 1st_read.bin. After that put ip.bin + 1st_read.bin
into the folder where your game data is stored, and make a
iso. Take a look at the Echelon tutorial how to do that.
You got now a fixed data.iso. Run Ipins and patch the iso
with the ip.bin file from the data folder.
Then burn the last session. You know....take a look
at the Echelon tutorial :)

6.Well when you do it correctly, your game must boot up now.
This works very well with and without CDDA.
---

I found 5E and B0 in these offsets:
0007D800
0007D810

001170A0
001170B0

001819A0
001819B0

00187620
00187630

00187D10
00187D20

Disc1
1st I changed the offsets 00187620 (5E to 96) and 30 (B0 to 00) and then 00187D10 (5E- 96) and 20 (B0- 00).
Used Echolon tools. Bruned it. Got a black screen after the 'Produced by or under license' stuff.

Disc2
Then I tried 001819A0 and 001819B0, 00187620 and 00187630. Got the same result (see disc 1).

Other discs
I burned some games in data/data mode too, but they went all back to the start screen after the Produced by or blabla logo.

I'm out of ideas, guyz...

-Suzuke-

Suzuke Oct 16, 2004 04:36 AM

Cdrwin
 
I use CDRECORD because cdrwin don't like my burner- I always get the error message 'burder is not supported' while tryin' to click on the 1st icon.

Maybe the games won't go any further as to the Sega Enterprises screen because they were burned with cdrecord? But I burned Utopia 1.1, Serial Slave, etc. with it, too. And these discs DO work.

???

draft Dec 12, 2004 09:07 AM

Can you contact me @ [email]draft64@yahoo.com[/email] . I might have some info to help you.


All times are GMT -5. The time now is 11:32 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1996-2009 CDROM-Guide.com. All rights reserved