CDROM-Guide forums

CDROM-Guide forums (http://www.cdrom-guide.com/forums/index.php)
-   Windows NT (http://www.cdrom-guide.com/forums/forumdisplay.php?f=68)
-   -   PCI IDE card problem - Slow CD transfer [DIY; ; winNT4] (http://www.cdrom-guide.com/forums/showthread.php?t=272662)

cdjim99 May 23, 2004 12:29 PM

PCI IDE card problem - Slow CD transfer [DIY; ; winNT4]
 
I'm using a PCI IDE card mainly to connect a newer hard drive to a older motherboard that doesn't support large sized drives. I have a CD-RW & DVD drive connected to the motherboard IDE connectors. This configuration worked but I can only get a MAX speed of about 19X, with and without the DMA enable on these drives. I know this motherboard and these drives have returned much better transfer rates when tested with CD Speed in the passed. I started thinking that maybe the PCI IDE card somehow interfeared with the motherboard IDE ports. I tried removing the PCI IDE card and using a older hard drive with the CD drives connected to the MB secondary IDE port. With the DMA enabled on these CD drives I was able to get above 19X and to the MAX specification of the drives. So, I proved that the PCI IDE card was somehow slowing down the MB IDE ports. While experimenting I found that the following configuration would also return MAX transfer rates:

1. The PCI IDE card install
2. Boot hard drive on PCI IDE PORT 1
3. CD drives on MB secondary IDE port,
4. A second hard drive connected to the MB primary IDE port. (This makes it work)

I sure don't know why connecting a second HD to the MB primary makes a differance but it does. It seems like Windows 98 is not turning on the DMA when only the CD drives are connected to the MB.
Note: I tested all this on a second system with a different motherboard, PCI IDE card, hard drive, and CD drives and of the same results.

System #1:
Windows 98SE
Mother board: DFI K6BV3 (VIA chipset)
CD Drives: ARTEC 16X DVD (DHM-G48), LiteOn 52x32x52 CD-RW LS523217S
PCI IDE Card: Promise ULTRA 100 TX2(updated with newest firmware)

System #2:
Windows 98SE
Mother board: Shuttle HOT-569 (Intel 430TX chipset)
CD Drives: ARTEC 16X DVD (DHM-G48), TDK 48x CD-RW
PCI IDE Card: Maxtor ATA133 (Uses Promise chip)

Any infomation about this would be very helpful. Thank you for your time.

cdjim99 Jun 09, 2004 09:43 PM

Update!...

I have found that booting from floppy without the PCI card and no hard drives connected to the motherboard also cause the CD-ROM transfer speed to MAX out around 19X. It looks like there is some kind of bug or quark in the Award V4.51PG BIOS that occurs only when on hard drives are connected to the on-board IDE ports. I tried every BIOS setting I could think of but nothing helped. So, at this point I have the following options:

1. Used the PCI IDE card for the hard drive & CD-ROM drive. This seems to work but was limitations: can't boot from CD, can't use for windows install, and Nero CD Speed locks up.

2. Used the PCI IDE card for the main hard drive, SEC MB IDE for CD-ROM drives, PRI MB IDE for second old hard drive. The second is used to "trick" the bIOS into working correctly and could also be used for data backup. The downside is older hard drives seem to a bit noisier. Does any board know how to spin down just one drive on a system?

3. Connect the Hard drive to the PRI MB IDE and CD-ROM drives to SEC MB IDE. The downside of this config is the HD transfer speed:

________WRITE________READ
PIC IDE: 22.8MB/S ------ 15MB/S
MB IDE: 13.3MB/S ------- 11.7M/S


All times are GMT -5. The time now is 04:11 PM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 1996-2009 CDROM-Guide.com. All rights reserved