View Single Post
  #13  
Old Apr 24, 2003, 02:58 PM
madison mods madison mods is offline
Veteran
 
Join Date: Jan 2002
Location: Madison, Wisconsin
Posts: 797
Default

The PRO just means it can be used on Jap., US, Euro systems. The latest version is 1.30. You want to make sure you're getting at least a 1.22, as the only diff. i, the 1.22 and the 1.3 is V8 compatability...
Reply With Quote